FZJ80 "Sputter" after water?

  • Hi Guest, you may choose a LIGHT or DARK theme that works best for you with the "Style Chooser" button at the bottom left on this page!
  • HTML tutorial

Michael

Rank VII
Staff member
Founder 500
Member

Pioneer II

8,507
Dublin, CA
First Name
Michael
Last Name
Murguia
Member #

0000

Ham Callsign
KM6YSL
Any FJ80 owners out there? EVERY time I plunge through water, my engine sputters until it dries out.

Anyone know what the culprit is? Is it as simple as water in the distributor?

Thanks in advance!

M
 
  • Like
Reactions: WakeUpAndSmellThe80

Matt_Whitman

Rank V
Member

Advocate II

2,093
Claremont Nh
Member #

0936

Yup. Sounds like something in the ignition system is not happy. My blazer did the something. Turned out being a cracked distributer cap. It was small enough that I overlooked it a few times. Old wires too.
 
  • Like
Reactions: Michael

mellowdave

Rank V
Founder 500
Member

Advocate II

1,788
Austin, Texas
Member #

267

dielectric grease on all plug wires and cap. see if that helps. if it doesn't, check for cracked wires or bad cap. I like to seal mine with grease around the bottom.
Concur completely with this, you're getting grounding somewhere in the ignition circuit, I'd think the coil is a likely culprit due to its location. I was actually just looking at mine the other day when i replaced my battery cables and thinking I should re-apply dialectric grease in that area. I am missing the splash guard around that shock tower, and I love doing water crossings so I'm certainly vulnerable.
 

MA_Trooper

Rank VI
Member

Influencer II

3,969
Methuen, MA
First Name
Chris
Last Name
BRV
Member #

0520

I would also double check the seal on all your snorkel/air box connection points. Though, if that were the issue you would likely see smoke out the tailpipe during the sputter.
 
  • Like
Reactions: Michael