Flexopower Lithium444 Setup Open Discussion/Questions

  • Hi Guest, you may choose a LIGHT or DARK theme that works best for you with the "Style Chooser" button at the bottom left on this page!

Baughb

Rank 0

Traveler I

60
Burbank, CA
First Name
Bob
Last Name
Salcedo
Wow, I feel badly for you guys because mine works as advertised with the exception of the LED indicators. When the unit is not charging, the LEDs are mostly all lit unless I 've drawn the battery down a good bit. When I am charging the unit using the 12v input , either solar or cigarette lighter, the LED's will flash down to the lowest one (towards the left) and continue during the charging process until all LEDs are solid. I'm really sorry this unit has messed you guys up.

My one communication with the company, via email, was chocked full of questions and was responded to with good answers... mostly about connectors, lengths of wire, leaving it plugged in all day, external temperature awareness. I do wish, and had suggested, that they replace the LEDs with a true "percentage of full" indicator. I did buy an inexpensive inline 12v DC meter and attached 15a Anderson connectors and put it in line with the Goal Zero cables and it worked as I had hoped showing (between the 444 and my CFX) how much draw was going on in real time within that circuit. I continue to use it with my CFX50 set at 34 degrees while out in the Sierra sun and it continues to work well for me.

I'm truly sorry for your troubles guys but, at this time, it has been a good thing for me.
 

OutdoorsBen

Rank IV
Member

Advocate III

1,059
Western Massachusetts
Member #

11214

I emailed South Africa yesterday and I actually found a USA based number for them and called this morning. Shocker to no one it just fwd’s to South Africa. The guy was super nice on the phone and said he would help. Let’s see what happens.
 

OutdoorsBen

Rank IV
Member

Advocate III

1,059
Western Massachusetts
Member #

11214

Looks like it did. Within hours I have been contacted and resolution is in motion. More details in the next few days when it’s all said and done. South African service is awesome.
 
  • Like
Reactions: Brewbud

OutdoorsBen

Rank IV
Member

Advocate III

1,059
Western Massachusetts
Member #

11214

Just a follow up, new unit arrived today. Can't say enough good things about South African service. USA service sucked. Can't quite speak to the longevity of the product, my first one went dead in 5months so let's see how this one fairs. My .02 to anyone with a problem is to try and reach the USA service but if you don't get an answer contact the South African service as they are significantly more helpful.
 
  • Like
Reactions: Baughb

OutdoorsBen

Rank IV
Member

Advocate III

1,059
Western Massachusetts
Member #

11214

I can tell you that immediately the LED lights are not accurate. My fridge has been going for 24hrs. Shows full bars, out a charge to it and it moved to charging the 3rd bar. Seems like no one who owns one will get away from the fault led lights. As long as it allows me to charge it I am ok with it though.
 

Baughb

Rank 0

Traveler I

60
Burbank, CA
First Name
Bob
Last Name
Salcedo
Yeah, the LED's are like your gasoline gauge... only worse. I use an inline dc volt meter to see the load drain and then do the math.
 

slomatt

Rank V

Influencer I

1,723
Bay Area, CA
The LEDs on my Flexopower used to go down as the charge was used, but now they seem to be stuck at "full power" all the time. As a test I've drawn about 24aH out of the battery and all the LEDs are still on. Very weird.
 

slomatt

Rank V

Influencer I

1,723
Bay Area, CA
The advertised rating of the Flexopower is 40Ah @ 12v, which is actually 37Ah if you do the math (444Wh/12v). After drawing more than 35Ah out of the battery it is now down to 2 of the 5 LEDs and the output voltage is 10.7v. Supposedly the BMS will shut down at 10v, so I'm interested to see how much more charge I can get out of it.